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Introduction 
 

The D-Case Weaver Stand Alone is a stand alone version of D-Case Weaver. 

 

For D-Case Weaver, please refer to this web site. 

http://www.dependable-os.net/tech/DCaseWeaver/index-e.html 

 

 

For installation of D-Case Weaver, please refer to “A1. Installation Guide”. 

 

http://www.dependable-os.net/tech/DCaseWeaver/index-e.html
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1 User Interface 

 
 

 

 

1. Menu bar 

2. Tool bar 

3. Drawing area for D-Case diagram 

4. Statistics information 

5. File information 

 

5 

1 

2 

3 

4 

Figure 1-1 User Interface 
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2 Creating and Saving a D-Case 
 

2.1 Creating a New D-Case 
 

To create a new D-Case, follow the procedure below. 

 

No. Procedure Result Note 

1 From the menu bar, select 

“File” > “New”. 

Empty D-Case diagram 

will be drawn in the 

drawing area. 

You can do the same by 

clicking the “New” button 

on the tool bar. 

 

 

2.2 Opening an Existing D-Case 
 

To open an existing D-Case, follow the procedures below. 

 

No. Procedure Result Note 

1 From the menu bar, select 

“File” > “Open”. 

The Open D-Case dialog 

will be displayed. 

You can do the same by 

clicking the “Open” button 

on the tool bar. 

2 Select a file from the File 

List on the dialog. 

  

3.1 Click the “OK” button. The D-Case diagram will 

be drawn in the drawing 

area and the dialog will 

close. 

 

3.2 Click the “Cancel” button The dialog will close.  

 

Open D-Case dialog 

 
Figure 2-1 Open D-Case dialog 

  

 

 

 

 

 

File List 
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2.3 Saving a D-Case 
 

To save a D-Case, follow the procedure below. 

 

Saving a D-Case 

 

No. Procedure Result Note 

1 From the menu bar, select 

“File” > “Save”. 

If the file has been saved, 

the D-Case will be saved. 

Otherwise, go to the 

following “Saving as a New 

D-Case” Procedure 2. 

You can do the same by 

clicking the “Save” button 

on the tool bar. 

 

 

Saving as a New D-Case 

 

No. Procedure Result Note 

1 From the menu bar, select 

“File” > “Save As”. 

The Save D-Case dialog 

will be displayed. 

 

2 From the File List on the 

dialog, select a directory in 

which to save the D-Case. 

The directory name will be 

displayed in the Directory 

field. 

 

3 Enter file name in the File 

Name field. 

  

4.1 Click the “OK” button. The D-Case will be saved 

and the dialog will close. 

 

4.2 Click the “Cancel” button. The dialog will close.  

 

Save D-Case dialog 

 
Figure 2-2 Save D-Case dialog 

 

 

File List 



©2014 JST D-Case Weaver Stand Alone Specification DEOS Project 

Page. 8  2014/03/01 

2.4 Saving as an Image File 
 

To save a D-Case diagram in the PNG image format, follow the procedures below. 

 

Saving entire D-Case diagram 

 

No. Procedure Result Note 

1 From the menu bar, select 

“File” > “Save As Image 

File”. 

The Save As Image File 

dialog will be displayed. 

 

2 Optionally, enter a scale 

factor in the Scale field. 

 If you want to save in half 

scale, enter “0.5” in the 

field. 

3.1 Click the “OK” button.  The image file will be 

saved. 

 

3.2 Click the “Cancel” button. The dialog will close.  

 

 

Saving a sub-tree rooted at a selected node 

 

No. Procedure Result Note 

1 Right-click a node. The context menu will be 

displayed. 

 

2 Select “Save As Image 

File”. 

The Save As Image File 

dialog will be displayed. 

 

3 Go to “Saving entire D-Case diagram” procedure 2 above. 

 

Limitation 

 

When the image width or height is over 8192 pixels, the image is split and the split images 

are saved. 

 

Save As Image File dialog 

 
Figure 2-3 Save As Image File dialog 
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3 Editing Functions 
 

3.1 Adding a Child Node 
 

To add a child node, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click a node. The context menu will be 

displayed. 

 

2 Select “Add Child”. Node types will be listed on 

the context menu. 

 

3 Select a node type to be 

added. 

A new node will be added.  

 

 

3.2 Editing a Node 
 

To edit a node, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click a node. The context menu will be 

displayed. 

 

2 Select “Edit Node” The Node Editor dialog will 

be displayed. 

 

3 Edit the node.   

4.1 Click the “OK” button. The changes will be 

applied to the node and the 

dialog will close. 

 

4.2 Click the “Cancel” button. The dialog will close.  
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Node Editor dialog 

 
Figure 3-1 Node Editor dialog 

 

Configurations 

 

Name Description 

Name Node name 

Type Node type 

Description Description 

Parameterized 

Description 

Parameters can be inserted into description as format below. 

 

{Parameter Name} 

 

In the node, the part of {Parameter Name} is replaced by the value 

that is set to the parameter. 

 

For the setting procedure, refer to “1 Parameters”. 

 

For Example) 

The number of users logged in at any one time is {LoginUserCount}. 

 

If both the Description and the Parameterized Description are set, the 

Parameterized Description is displayed preferentially. 

Responsibility Name: Name of the responsible person 

E-Mail: E-Mail address of the responsible person 

Icon URL: Icon URL of the responsible person 

Valid Until Expiration date of the node 
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The configurations are displayed on the node as below. 

 

 

 
 

 

3.3 Deleting a Node 
 

To delete a node, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click a node. The context menu will be 

displayed. 

 

2 Select “Delete Node”. The node will be deleted.  

 

 

3.4 Changing an order of sibling nodes 
 

To change an order of sibling nodes, follow the procedures below. 

 

No. Procedure Result Node 

1 Right-click a node. The context menu will be 

displayed. 

 

2 Select “Sibling Order”. Sibling Order dialog will be 

displayed. 

 

3 Change the order of sibling 

nodes by dragging and 

dropping the node 

  

4.1 Click the “OK” button. The changes will be 

applied and the dialog will 

close. 

 

4.2 Click the “Cancel” button. The dialog will close.  

 

Figure 3-2 Description of Node 

Name Type 

Description 

or 

Parameterized 

Description 

Valid Until Responsibility:Name 

Responsibility:Icon 
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Sibling Order Dialog 

 
Figure 3-3 Sibling Order Dialog 

 

You can change the order of sibling nodes by dragging and dropping the node. 

 
 

 

3.5 Adding a Link 
 

To add a link, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click a node. The context menu will be 

displayed. 

 

2 Select “Add Link”.  “Parent” and “Child” will 

be displayed on the context 

menu. 

 

3 Select “Parent” or “Child” The link, a red arrow for 

editing, will be displayed. 

When “Parent” is selected, 

the link is displayed on 

parent side on the node. 

When “Child” is selected, 

the link is displayed on 

child side. 

4 Drag the starting or ending 

point of the link and drop it 

on a node to link. 

  

5 Click places other than the 

starting and ending point 

of the link. 

The changes will be 

applied and the link will be 

hidden. 

 

 

Figure 3-4 Changing the Order of Sibling Nodes 

Drag&Drop 
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Figure 3-5 Editing a Link 

 

 

3.6 Editing a link 
 

To edit a link, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click a link. The context menu will be 

displayed. 

 

2 Select “Edit Link”. Edit Link dialog will be 

displayed. 

 

3 Edit the link.   

4.1 Click the “OK” button. The changes will be 

applied to the link and the 

dialog will close. 

 

4.2 Click the “Cancel” button. The dialog will close.  

 

Edit Link dialog 

 
図 3-1 Edit Link dialog 

 

Configurations 

 

Name Description 

Name Link name 

Type Link type 

Attachment Attachment 

 

 

3.7 Editing a connection of a link 
 

To edit a connection of a link, follow the procedures below. 

Drag & Drop 
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No. Procedure Result Note 

1 Click a link. The link, a red arrow for 

editing, will be displayed. 

 

2 Go to “Adding a Link” procedure 4 above. 

 

 

3.8 Deleting a Link 
 

To delete a link, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click a link. The context menu will be 

displayed. 

 

2 Select “Delete Link”. The link will be deleted.  

 

 

3.9 Editing Properties 
 

You can display file information and edit description. 

 

The file information is displayed in the upper left portion of the drawing area. It has a file 

name at upper part and a description at lower part. 

The “Edit” button is displayed when the mouse cursor hover over the file information. 

 

 
Figure 3-2 File Information 

 

 
Figure 3-3 Edit Button 

 

To edit the description, follow the procedures below. 

 

No. Procedure Result Note 

1 From the menu bar, select 

“File” > “Properties”. 

The Properties dialog will 

be displayed. 

You can do the same by 

clicking the Edit button. 

2 Edit description   

4.1 Click the “OK” button. The changes will be  
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applied and the dialog will 

close. 

4.2 Click the “Cancel” button. The dialog will close.  

 

Properties dialog 

 
Figure 3-4 Properties dialog 

 

 

3.10 Undoing and Redoing 
 

To undo, follow the procedure below. 

 

No. Procedure Result Note 

1 From the menu bar, select 

“Edit” > “Undo”. 

The previous operation will 

be removed. 

You can do the same by 

clicking the Undo button 

on the tool bar. 

 

 

To redo, follow the procedure below. 

 

No. Procedure Result Note 

1 From menu bar, select 

“Edit” > “Redo”. 

The previous undo 

operation will be removed. 

You can do the same by 

clicking the Redo button 

on the tool bar. 

 

When undoing and/or redoing cannot be performed, the Undo and/or Redo items on the 

menu bar and the Undo and/or Redo button on the tool bar are disabled. 

 

 
Figure 3-6 Undo / Redo button 
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4 Attachment 
 

4.1 Attaching a URL 
 

To attach a URL, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click a node. The context menu will be 

displayed. 

 

2 Select “Attachment”. The Attachment dialog will 

be displayed. 

 

3 Enter a URL in the URL 

field. 

  

4.1 Click the “OK” button. The changes will be 

applied and a clip icon will 

be attached to the node and 

the dialog will close. 

 

4.2 Click the “Cancel” button. The dialog will close.  

 

You can remove the attachment by blanking the URL field. 

 

Attachment dialog 

 
Figure 4-1 Attachment dialog 

 

4.2 Opening an Attachment 
 

To open an attachment, follow the procedure below. 

 

No. Procedure Result Note 

1 Click the clip icon in a 

node. 

The attachment will open.  

 

 
Figure 4-2 Clip icon 
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5 Searching for a Node 
 

To search for a node, follow the procedures below. 

 

No. Procedure Result Note 

1 Enter the name of the node 

to be searched in the 

Search field on the tool bar. 

The node candidates will 

be listed every time a 

character is entered. 

 

2 From the list of node 

candidates, select a node. 

The diagram will move as 

the selected node is 

displayed in center of the 

screen. 

 

 

Search Node Tool 

 

 
Figure 5-1 Search Node Tool 

 

 

 

6 Viewing Statistics Information 
 

You can show or hide statistics information by using the Show/Hide Statistics Information 

Tool. 

 

Show/Hide Statistics Information Tool 

 
Figure 6-1 Show/Hide Statistics Information Tool 
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7 Repository Operations 
 

The root directory of a repository as follows: 

 

In case of Ubuntu 

/home/[User Name]/DCaseWeaver/Documents/ 

 

In case of Windows  

C:¥Users¥[User Name]¥DCaseWeaver¥Documents¥ 

 

You can do the following operations for files and directories under the root directory. 

 Creating a directory 

 Deleting a file or a directory 

 Importing a file 

 Comparing D-Case documents 

 

7.1 Common Operations 
 

To open the Repository Browser, follow the procedure below. 

 

No. Procedure Result Note 

1 From the menu bar, select 

“Document” > “Browse”. 

The Repository Browser 

will be displayed. 

 

 

The following operations in Section 7.2 to 7.5 start from this state. 

 

Repository Browser 

 
Figure 7-1 Repository Browser 

 

7.2 Deleting a File or Directory 
 

To delete a file or directory, follow the procedures below. 

 

No. Procedure Result Note 

1 From the File List, select a 

file or directory. 

  

File List 
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2 Click the “Delete” button. The selected file or 

directory will be deleted. 

 

 

7.3 Importing a File 
 

To import a file, follow the procedures below. 

 

No. Procedure Result Note 

1 From the File List, select a 

destination directory to 

import a file. 

  

2 Click the “Import” button. The Import dialog will be 

displayed. 

 

3 In the dialog, select a file 

by clicking the “Choose 

File” button. 

 The label of the button 

may differ in browsers 

other than Chrome. 

4 Enter a file name in the 

File Name field. 

  

5.1 Click the “OK” button. The file will be imported 

and the dialog will close. 

 

5.2 Click the “Cancel” button. The dialog will close.  

 

Import dialog 

 
Figure 7-2 Import dialog 

 

 

7.4 Creating a Directory 
 

To create a directory, follow the procedures below. 

 

No. Procedure Result Note 

1 From the File List, select a 

directory. 

 A new directory will be 

created in the selected 

directory. 

2 Click the “Make Directory” 

button.  

The Make Directory dialog 

will be displayed. 

 

3 Enter a directory name.   

4.1 Click the “OK” button. A new directory will be 

created and the dialog will 

close. 
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4.2 Click the “Cancel” button. The dialog will close.  

 

Make Directory dialog 

 
Figure 7-3 Make Directory dialog 

 

 

7.5 Comparing D-Case Documents 
 

To compare D-Case documents, follow the procedures below. 

 

No. Procedure Result Note 

1 From the menu bar, select 

“Document” > “Compare 

To” 

The Browser will be 

displayed. 

 

2 From the Browser, select a 

file to compare. 

  

3.1 Click the “OK” button. The comparison result will 

be displayed and the dialog 

will close. 

 

3.2 Click the “Cancel” button. The dialog will close.  

 

Comparison Result 

 

When nodes or links are deleted from selected D-Case document, they are displayed with a 

blue color. 

When nodes or links are modified, they are displayed with a red color. 

 
Figure 7-4 Comparizon Result 
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8 D-Script Parameters 
 

You can set a D-Script and its parameters for performing the D-Script in a node. 

 

 

8.1 D-Script Template File 
 

For D-Script Template File, please refer to D-Case Weaver Specification. 

 

8.2 CGI Program for Deploying Configuration Files 
 

For CGI Program for Deploying Configuration Files, please refer to D-Case Weaver 

Specification. 

 

8.3 Setting up Configurations 
 

To set up, follow the procedures below. 

 

No. Procedure Result Note 

1 From the menu bar, select 

“Edit” > “Preferences”. 

The Preference dialog will 

be displayed. 

 

2 Set up the configurations 

of the D-Script. 

  

3.1 Click the “OK” button. The configurations will be 

applied and the dialog will 

close. 

 

3.2 Click the “Cancel” button. The dialog will close.  

 

 

Configurations 

 

Name Description 

Template Path The location of a D-Script template file 

 

For example: 

 /project1/d-script.xml 

Deploy URL The URL of a deploy application 

 

For example: 

 http://localhost/cgi-bin/deploy.php 

 

 

8.4 Editing a D-Script 
 

To select a D-Script and edit its parameters, follow the procedures below. 

 

No. Procedure Result Note 
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1 Right-click a node. The context menu will be 

displayed. 

 

2 Select “Edit D-Script”. The D-Script dialog will be 

displayed. 

 

3 Select a D-Script from the 

drop-down menu. 

Information of selected 

D-Script will be displayed. 

 

4 Edit the D-Script 

parameters. 

  

5.1 Click the “OK” button. The parameters will be 

applied and the dialog will 

close. 

 

5.2 Click the “Cancel” button. The dialog will close.  

 

For the schema of the D-Script parameter that is added to a node, refer to D-Case Weaver 

Specification. 

 

D-Script dialog 

 
Figure 8-1 D-Script dialog 

 

 

8.5 Deploying D-Script Configuration Files 
 

To create and deploy D-Script configuration files, follow the procedure below. 

 

No. Procedure Result Note 

1 From the menu bar, select 

“D-Script” > “Deploy”.  

D-Script configuration files 

will be generated and be 

deployed. 

The D-Script configuration 

files are deployed in the 

directory specified with 

config_path in a D-Script 

template file. 

 

Drop-Down menu 
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9 Monitoring 
 

D-Case Weaver gets each node status from a status server and changes the node color 

according to the status. 

 

The status is obtained in text format from a status server by HTTP protocol. 

 

 HTTP METHOD 

GET 

 

 REQUEST 

 PARAMETERS 

No parameters 

 BODY 

No data 

 

 RESPONSE 

 

The response is text formatted as follows. 

 

id=”Goal node ID” status=”Status” message=”Message” 

 

The line delimited by a new line character is repeated every Goal. 

 

The character encoding must be UTF-8. 

 

 

Parameters 

 

Name Description 

Goal node ID ID of the node of the monitoring target 

Status Select one of the following strings 

 normal 

 running 

 error 

Message Message 

 

 

Status and Color 

 

Status Color 

normal White 

running Yellow 

error Red 
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9.1 Setting up Configurations 
 

To set up, follow the procedures below. 

 

No. Procedure Result Note 

1 From the menu bar, select 

“Edit” > “Preferences”. 

The Preference dialog will 

be displayed. 

 

2 Set up the configurations of 

Node Status Monitor. 

  

3.1 Click the “OK” button. The configurations will be 

applied and the dialog will 

close. 

 

3.2 Click the “Cancel” button. The dialog will close.  

 

 

Configurations 

 

Name Description 

URL The URL of a status server 

 

For example: 

 http://localhost/cgi-bin/node-status.wsgi 

Interval[ms] The monitoring interval, in milliseconds 

 

For example: 

 10000 

 

 

9.2 Starting a Monitoring 
 

To start a monitoring, follow the procedure below. 

 

No. Procedure Result Note 

1 From the menu bar, select 

“Monitor” > “Start”. 

The monitoring will start.  

 

 

9.3 Stopping a Monitoring 
 

To stop a monitoring, follow the procedure below. 

 

No. Procedure Result Note 

1 From the menu bar, select 

“Monitor” > “Stop”. 

The monitoring will stop.  
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9.4 Sample Program 
 

For Sample Program, refer to D-Case Weaver Specification. 
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10 Cooperation Function with DS-Bench 
 

D-Case Weaver cooperates with DS-Bench to provide the functions below. 

 Getting test scenarios from DS-Bench. 

 Setting up parameters of a test scenario 

 Starting a test scenario 

 Adding a node according to the evaluation result of a test scenario 

 

For the installation and the usage of DS-Bench/Test-Env, refer to the following documents 

and web site. 

 DS-Bench/Test-Env Specification (DEOS-FY2013-BS-01E) 

 DS-Bench/Test-Env Setup Manual(DEOS-FY2013-BI-01E) 

 DS-Bench/Test-Env Execution Manual(DEOS-FY2013-BT-01E) 

 http://www.dependable-os.net/tech/DSBenchDCloud/index-e.html 

 

10.1 Setting up Configurations 
 

To set up the cooperation function with DS-Bench, follow the procedures below. 

 

No. Procedure Result Note 

1 From the menu bar, select 

“Edit” > “Preferences”. 

The Preference dialog will 

be displayed. 

 

2 Set up the configuration of 

the DS-Bench. 

  

3.1 Click the “OK” button.  The configurations will be 

applied and the dialog will 

close. 

 

3.2 Click the “Cancel” button. The dialog will close.  

 

 

Configurations 

 

Name Description 

Name The name of DS-Bench server 

URL The URL of DS-Bench server 

 

 

10.2 Selecting a test scenario 
 

To select a test scenario prepared by DS-Bench, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click a Strategy 

node. 

The context menu will be 

displayed. 

 

2 Select “DS-Bench” > 

“Select Scenario”. 

The Scenario List dialog 

will be displayed. 

 

3 Select a test scenario.   

4.1 Click the “OK” button. The Goal node will be  

http://www.dependable-os.net/tech/DSBenchDCloud/index-e.html
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added and the dialog will 

close. 

4.2 Click the “Cancel” button. The dialog will close.  

 

By the procedures on the S_1 Strategy node, the G_1 Goal node is added to the Strategy 

node as below. 

 

 
Figure 10-1 Selecting a test scenario 

 

Scenario List dialog 

 
Figure 10-2 Scenario List dialog 

 

 

10.3 Setting up Parameters 
 

To set up parameters of a scenario, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click the Goal node 

added in Section 10.2. 

The context menu will be 

displayed. 

 

2 Select “DS-Bench” > “Set 

Parameters”. 

The Scenario Parameters 

dialog will be displayed. 

 

3 Set parameters   

4.1 Click the “OK” button. The parameters will be 

applied and the dialog will 

close. 

 

4.2 Click the “Cancel” button. The dialog will close.  

 

The parameters are test scenario specific. 
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Scenario Parameters dialog 

 
Figure 10-3 Scenario Parameters dialog 

 

 

10.4 Starting a Test Scenario 
 

To start a test scenario, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click the Goal node 

added in Section 10.2 

The context menu will be 

displayed. 

 

2 Select “DS-Bench” > 

“Execute” 

The test scenario will 

start. 

 

 

During execution of a test scenario, the execution status is displayed in the node. 

 
Figure 10-4 Execution Status 
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After completion of a test scenario, a node is added according to the evaluation result. 

If the result is satisfactory, a blue Evidence node is added. 

 
Figure 10-5 Satisfactory 

 

 

If the result is unsatisfactory, a red “Undeveloped” node is added. 

 

 
Figure 10-6 Unsatisfactory 

 

You can see the execution result details screen of DS-Bench if you click the clip icon in the 

node. 
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10.5 Stopping a Test Scenario 
 

To stop a test scenario, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click the Goal node 

added in Section 10.2. 

The context menu will be 

displayed. 

 

2 Select “DS-Bench” > 

“Cancel” 

The test scenario will stop.  
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11 Module 
 

D-Case Weaver provides a modularization function which saves a part of D-Case as a new 

file. The modularized part is represented as a module node in the current D-Case. 

 

11.1 Modularizing 
 

To create a module, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click a node. The context menu will be 

displayed. 

 

2 Select “Module” > 

“Modularize”.  

The Modularize dialog will 

be displayed. 

 

3 Enter the name of the 

module. 

  

4.1 Click the “OK” button. The modularized sub-tree 

will be saved as a new file 

and be represented as a 

module node in the 

diagram. And the dialog 

will close. 

 

4.2 Click the “Cancel” button The dialog will close.  

 

Modularize dialog 

 
Figure 11-1 Modularize dialog 

 

If the G_2 node in Figure 11-2 is modularized, the diagram is as in Figure 11-3. 

 

Before Modularization 

 
Figure 11-2 Before Modularization 
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After Modularization 

 
Figure 11-3 After Modularization 

 

The destination to save the module 

The destination directory is a directory that name is a original D-Case file name without 

extension(.dcase). The module is saved in the directory. 

11.2 Selecting a Module 
 

To select a module, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click a Module or 

Goal node. 

The context menu will be 

displayed. 

 

2 Select “Module” > “Select 

Module”. 

The Select Module dialog 

will be displayed. 

 

3 Select a module.   

4.1 Click the “OK” button. The module will be set in 

the node and the dialog 

will close. 

 

4.2 Click the “Cancel” button. The dialog will close.  

 

Select Module dialog 

 
Figure 11-4 Select Module dialog 

 

 

11.3 Un-modularizing 
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To un-modularize, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click a Module node The context menu will be 

displayed. 

 

2 Select “Module” > 

“Un-modularize”. 

The module will be 

un-modularized. 

 

 

If the Figure 11-3 is un-modularized, the diagram is as below. 

 

 
Figure 11-5 Un-modularizing a Module 

 

 

11.4 Showing/Hiding inside of a Goal/Module Node 
 

To show/hide inside of a Goal/Module node, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click a modularized 

node. 

The context menu will be 

displayed. 

 

2 Select “Module” > 

“Show/Hide Module” > 

“Show”. 

The D-Case which was 

modularized will be 

displayed in the node. 

To hide the expanded 

view, select “Hide”. 

You can do the same by 

clicking the +/- icon in the 

node. 
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When the inside of Module node in Figure 11-3 is shown, the diagram changes as below. 

 

 
Figure 11-6 Exposed View of a Node 
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12 Parameters 
 

You can set parameters in a Parameter node. The sub tree that the root node is the parent 

node of the Parameter node refers the parameters. 

The parameters can be available by setting in the “Parameterized Description” with the 

following format. 

 

{Parameter Name} 

 

Setting example of Parameterized Description  

 

The number of users logged in at any one time is {LoginUserCount} 

The parameter is presented as follows. 

 

 
Figure 12-1 Setting example of Parameter 

 

 

12.1 Opening the Parameters dialog 
 

To open the Parameters dialog, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click on a Parameter 

node. 

The context menu will be 

displayed. 

 

2 Select “Parameters” The Parameters dialog will 

be displayed. 

 

 

Parameters dialog 

 
Figure 12-2 Parameters dialog 
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12.2 Adding Parameters 
 

To add parameters, follow the procedures below. 

 

No. Procedure Result Note 

1 Click the “Add” button on 

the Parameters dialog. 

The Edit Parameter dialog 

will be displayed. 

 

2 Set up the configurations.   

 

 

Configurations 

 

Name Description 

Name Parameter name 

Type Parameter type 

Value Value 

Length Number of characters of the Value ( shown if the Type is string ) 

Range Range of the Value ( shown if the Type is int, double and raw ) 

Enumeration Items List of enumerated constant value ( shown if the Type is enum ) 

An enumerated constant value can be added with “Add” button. 

An enumerated constant value can be deleted with “Delete” 

button. 

 

 

12.3 Editing a Parameter 
 

To edit a parameter, follow the procedure below. 

 

No. Procedure Result Note 

1 Select a parameter to edit.   

2 Click the “Edit” button on 

the Parameters dialog. 

The Edit Parameter will be 

displayed. 

 

3 Edit parameter   

 

 

12.4 Deleting a Parameter 
 

To delete a parameter, follow the procedures below. 

 

No. Procedure Result Note 

1 Select a parameter to 

delete. 

  

2 Click the “Delete” button 

on the Parameters dialog. 

The parameter will be 

deleted. 
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Appendix 
 

A1. Installation Guide 
 

System Requirements 
 

We have confirmed that D-Case Weaver works in the following system environments. 

 

 OS 

 Ubuntu 12.04 32bit / 64bit 

 Windows Vista / 7 

 

Download 

 

You can download the D-Case Weaver Stand Alone version from the following URL. 

http://www.dependable-os.net/tech/DCaseWeaver/index-e.html 

 

Please download one of the following depending on your environment. 

- Debian package i386 / amd64 

- Windows ( zip file ) 

 

Installation and execution 

 

In case of Debian package i386 / amd64 

 

Execute the following commands. 

$ sudo apt-get install libqtcore4 libqtwebkit4 libqt4-xml libqt4-network libicu48 

$ sudo dpkg -i dcase-weaver-sa_1.0.0_i386( or amd64 ).deb 

$ dcaseweaver 

(The filename of the package may change depending on the version.) 

 

 

In case of Windows 

 

Right-click on the downloaded dcase-weaver-sa_1.0.0_win.zip file and “Extract All” the file 

to any directory on your computer. 

 

Double-click the dcaseweaver.exe in the extracted dcase-weaver-sa_1.0.0_win directory. 

(The filename of the package may change depending on the version.) 

 

http://www.dependable-os.net/tech/DCaseWeaver/index-e.html
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